В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
propprap
propprap
01.09.2021 19:46 •  Информатика

Составьте программу, которая напечатает числа в виде следующе таблицы. воспользуйтесь вложенными циклами. кол-во чисел в строке (м) и кол-во строк (n) задать с клавиатуры входные параметры. ниже пример для значения m=5 и n=4: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20

Показать ответ
Ответ:
katya8631
katya8631
16.07.2020 10:28

Бит

Единицей измерения количества информации является бит – это наименьшая (элементарная) единица.

1бит – это количество информации, содержащейся в сообщении, которое вдвое уменьшает неопределенность знаний о чем-либо.

 

Байт

Байт – основная единица измерения количества информации.

Байтом называется последовательность из 8 битов.

Байт – довольно мелкая единица измерения информации. Например, 1 символ – это 1 байт.

 

Производные единицы измерения количества информации

1 байт=8 битов

1 килобайт (Кб)=1024 байта =210 байтов

1 мегабайт (Мб)=1024 килобайта =210 килобайтов=220 байтов

1 гигабайт (Гб)=1024 мегабайта =210 мегабайтов=230 байтов

1 терабайт (Гб)=1024 гигабайта =210 гигабайтов=240 байтов

Запомните, приставка КИЛО в информатике – это не 1000, а 1024, то есть 210 .

0,0(0 оценок)
Ответ:
lenichk
lenichk
31.03.2020 12:15
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота