В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
olenapolova4
olenapolova4
13.07.2021 19:28 •  Информатика

Составьте программу, которая определяет к какой группе относится введенный символ (с) – к цифрам, заглавным или прописным буквам. на экран должна выводиться фраза «символ с – это …», где вместо … пишется соответствующая группа (например, «символ r – это заглавная буква»).

Показать ответ
Ответ:
cadatik04
cadatik04
13.08.2020 18:24
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var c:=ReadlnChar('Введите символ');
  case c of
  'A'..'Z': Writeln('Символ ',c,'- это прописная латинская буква');
  'a'..'z': Writeln('Символ ',c,'- это строчная латинская буква');
  'А'..'Я','Ё': Writeln('Символ ',c,'- это прописная русская буква');
  'а'..'я','ё': Writeln('Символ ',c,'- это строчная русская буква');
  '0'..'9': Writeln('Символ ',c,'- это цифра');
  else Writeln('Символ ',c,'- это специальный знак')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота