В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу,которая определяет какое из трех введенных с клавиатуры чисел является средним.если среди чисел есть равные,то вывести сообщение"ошибка"

Показать ответ
Ответ:
Madonkg
Madonkg
07.10.2020 13:24
Var a,b,c: integer;
begin
  write('числа: '); readln(a,b,c);
  if a>b then swap(b,c);
  if c<a then swap(a,c);
  if b>c then swap(b,c);
  if (a=b) or (b=c) then writeln('ошибка')
  else writeln('среднее: ',b);
end.

числа: 9 17 8
среднее: 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота