В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
igordergaysov
igordergaysov
13.11.2022 08:08 •  Информатика

Составьте программу , которая определяет, количество цифр 2 у числа, введенного с клавиатуры, через я не могу составить именно тело цикла. вот что есть program z_15; var num, f, f2 : longint; var kn2 : byte; begin f: =0; kn2: =0; writeln('enter number'); writeln('p.s. number > zero'); readln(num); while num> 0 do begin if f = 2 then kn2: =kn2 + 1; end; writeln('kn2 is =',kn2); end.

Показать ответ
Ответ:
eryana
eryana
02.10.2020 21:49
Program Z_15;
VAR Num, F, F2 : longint;
var kn2 :byte;

begin
F:=0;
kN2:=0;
writeln('Enter Number');
writeln('P.S. Number > Zero');
readln(NUM);
While Num>0 do
begin
F:=num mod 10;
num:=num div 10;
if F = 2 then
KN2:=KN2 + 1;
end;
Writeln('KN2 is =',KN2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота