В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
justfrog44Arch
justfrog44Arch
15.02.2021 04:30 •  Информатика

Составьте программу, которая определяет возможность получения слово "мать" из введенной строки.

Показать ответ
Ответ:
777angel777likoy8mjs
777angel777likoy8mjs
04.11.2022 23:29
Информационный вес символа при алфавитном подходе считается, что каждый символ текста имеет определенный информационный вес, информа­ционный вес символа зависит от мощности алфавита. а ка­ким может быть наименьшее число символов в алфавите? оно равно двум! скоро вы узнаете, что такой алфавит ис­пользуется в компьютере. он содержит всего 2 символа, ко­торые обозначаются цифрами «0» и «1». его называют дво­ичным алфавитом. изучая устройство и работу компьютера, вы узнаете, как с всего двух символов можно пред­ставить любую информацию. информационный вес символа двоичного алфавита принят за единицу информации и называется 1 бит.
0,0(0 оценок)
Ответ:
anonymous18
anonymous18
05.10.2021 16:06
Создаёшь в папке с программой два текстовых файла с именами "1.txt." и "output.txt". В первый записываешь 8 чисел без пробелов и запятых ("22031991", например).

type  matrix = array [1..8] of integer;var  F, output: text;  i, n, cc, sum: integer;  c: char;  x: matrix;  ma: real;
procedure convert (var c: char; var cc: integer);begin  if c='1' then cc:=1;  if c='2' then cc:=2;  if c='3' then cc:=3;  if c='4' then cc:=4;  if c='5' then cc:=5;  if c='6' then cc:=6;  if c='7' then cc:=7;  if c='8' then cc:=8;  if c='9' then cc:=9;  if c='0' then cc:=0;end;
procedure sorting (n: integer; x: matrix);begin  for n:=1 to 7 do begin    if x[n]>x[n+1] then swap(x[n],x[n+1]);  end;end;
begin  Assign(F, '1.txt');  Reset(F);  for i:=1 to 8 do begin    read(F, c);    convert(c,cc);    x[i]:=cc;  end;  Close(F);
  sorting(n,x);  sum:=x[1]+x[2]+x[3]+x[4]+x[5]+x[6]+x[7]+x[8];  ma:=sum/8;    Assign(output, 'output.txt');  rewrite(output);  writeln(output, sum); writeln(output, ma);  Close(output);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота