В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
7Tamada7
7Tamada7
05.04.2022 12:53 •  Информатика

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 5 файлов в байтах (от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты. результат выводится в строку.

Показать ответ
Ответ:
Ruslanchik111
Ruslanchik111
23.05.2020 19:03

var

 a:array[1..5]of integer;

 i:integer;

begin

 for i:=1 to 5 do read(a[i]);

for i:=1 to 5 do write(a[i],' ');

writeln;

for i:=1 to 5 do if a[i]>=1024 then writeln(a[i] div 1024);

writeln;

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота