В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vladakolyrova
vladakolyrova
09.07.2022 16:54 •  Информатика

Составьте программу, которая по введенному k – числу цветков печатает фразу «в букете k цветков», причем согласовывает окончание слова «цветок» с числом k. на паскале

Показать ответ
Ответ:
arslanmax
arslanmax
27.07.2020 11:24
Через Case :
Var
k:integer;
Begin
WriteLn('Введи число k');
ReadLn(k);
if k in[11..19] then WriteLn('В букете ',k,' цветков')
else
Case k mod 10 of
1:WriteLn('В букете ',k,' цветок');
2..4:WriteLn('В букете ',k,' цветка');
0,5..9:WriteLn('В букете ',k,' цветков');
end
End.

Через if :

Var
k:integer;
Begin
WriteLn('Введи число k');
ReadLn(k);
if k in[11..19] then WriteLn('В букете ',k,' цветков')
else
Begin
if k=1 then WriteLn('В букете ',k,' цветок');
if k mod 10 in[2..4] then WriteLn('В букете ',k,' цветка');
if (k mod 10 in[5..9])or(k=0) then WriteLn('В букете ',k,' цветков');
end
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота