В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tvin2005
tvin2005
10.01.2021 01:18 •  Информатика

Составьте программу, которая по введенному вами k - числу грибов печатает фразу , причем согласовывает окончание слова с числом k. количество грибов может быть любым целым числом: 1, 3, 34, 127 и т.д. окончание фразы определяется значением последней цифры.

Показать ответ
Ответ:
IHannahI
IHannahI
07.07.2020 13:20
Var g,i:integer;
begin 
read(g);
if (g=1) or ((g>20) and (g mod 10=1)) then begin writeln('Мы нашли в лесу ',g,' гриб'); i:=1; end;
if ((g mod 10>1) and (g mod 10<5)) or ((g>21) and (g mod 10>1) and (g mod 10<5)) then begin writeln('Мы нашли в лесу ',g,' гриба'); i:=1; end;
if i=0 then writeln('Мы нашли в лесу ',g,' грибов');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота