В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
анна3031
анна3031
22.01.2021 04:00 •  Информатика

Составьте программу ,которая позволяет удалить символы t из строки s.строка s и символ t,который надо удалить,вводятся с клавиатуры

Показать ответ
Ответ:
milanashavhalo1992
milanashavhalo1992
23.06.2020 15:27
Тогда вот, все по букве задания

var
  s : string;
  t : char;
  i : integer;
begin
  readln (s);
  read (t);
  i := 1;
  while (i <= length (s)) do
  begin
    if s[i] = t then delete (s, i, 1)
    else i := i + 1;
  end;
  writeln (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота