В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
boss23242
boss23242
23.03.2020 15:00 •  Информатика

Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно

Показать ответ
Ответ:
Эноа
Эноа
04.10.2020 12:19
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
  var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
  Write('Отрицательных- ',t.Count,'; их номера ');
  t.Select(x->x[1]).Println
end.

Пример
Введите 10 чисел, нажмите Enter
 3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота