В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Artemkotkot20
Artemkotkot20
19.03.2023 02:50 •  Информатика

Составьте программу, которая позволяет заменить в строке слово мама на слово папа

Показать ответ
Ответ:
pomogite228plez
pomogite228plez
02.08.2020 16:53
Var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s);  // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
 begin  
Delete(s, i, 4);  // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа 
Insert('папа', s, i);  // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота