В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
karina072006
karina072006
21.05.2022 03:46 •  Информатика

Составьте программу, которая преобразует расстояния до некоторых ближайших к земле звёзд из световых лет в парсеки(1 пк = 3, 26 св. лет). проксима центавра 4,24 св. лет альфа центавра 4,37 св. лет сириус 8,58 св. лет эпсилон эридана 10,52 св. лет процион 11,4 св. лет эпсилон индейца 11,82 св. лет тау кита 11,89 св. лет тема : преобразование массива, информатика.

Показать ответ
Ответ:
Амон11111
Амон11111
09.10.2020 07:35

#include <iostream>

int main() {

for(;;) {

double sg, pk_1 = 3.26;

std::cin >> sg; // Вводишь расстояние до звезды

std::cout << sg / pk_1  << std::endl;

if (sg == 0) break; // если вводишь 0, программа завершается

}

return 0;

}

// программа выводит на экран значение расстояния до звезды в парсеках

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота