В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ksenyaandreevn
ksenyaandreevn
10.02.2021 23:03 •  Информатика

Составьте программу, которая проверяет введенные числа на четырехзначность, а затем суммирует последнюю цифру числа. pascal

Показать ответ
Ответ:
titomeister
titomeister
09.10.2020 06:13

Как-то так:


//fpc 3.0.0


program HelloWorld;


var

 total: integer;   // результат суммирования

 ent, last: integer;  // ввод, подсчет


begin


total := 0; // начальная сумма


// 30 можно поменять на любое число, чтоб цикл не шел вечно. А если надо вечно, то поменять условие на 1 < 2

while total <= 30 do

begin


 // просим число

 write('Enter number: ');

 readln(ent);


 // получаем только 4-х значные

 if (ent < 1000) or (ent > 9999) then

  Continue;


 // берем последнюю цифру

       last:= ent mod 1000;

       last:= last mod 100;

       last:= last mod 10;

       

       // складываем

       total:= total + last;


       // выводим результат

 writeln(total);

end;    

end.


Результат можно посмотреть тут: https://rextester.com/ENTY66578

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота