В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nikTNG
nikTNG
29.09.2020 20:46 •  Информатика

Составьте программу, которая реализует
ввод с клавиатуры трех произвольных
положительных чисел а, b и c. Возводит в
квадрат только нечетные числа, а четные
оставляет без изменения. Новые значения
выводит на экран.
2.Некоторый автомат может за два
числа и выполнить 3 команды. Составьте
программу, которая по команде 1
преобразует имеющуюся пару чисел (х, у) в
пару (х-у, у), по команде 2 преобразует пару
чисел (х, у) в пару (х+у, у), по команде 3
преобразует пару (x, у) в (у, х).
3.Составьте программу, которая по коду
операции N выполняет над целыми числами
а и b (b0) указанное действие и выводит
результат. Арифметические действия
(операции) над числами обозначены: 1 –
сложение, 2 – вычитание, 3 – умножение, 4
– деление.

Показать ответ
Ответ:
lada48
lada48
03.06.2021 20:14
25 (10cc) =2^4+2^3+2^0 =11001 (2cc)
19 (10cc)=2^4+2^1+2^0=10011 (2cc)

используя формулу А→В =¬А+В приводим данную формулу в условии к виду:
(X&25=0)+(X&19≠0) + (Х&A≠0)=1

рассмотрим случай, когда
(Х&25 =0) +(X&19≠0) =0   и  (Х&A≠0)=1

так как 25 = 11001, то (X&25=0) = 0   (т.е. конъюнкция будет "ложь")
при Х={1; 1000; 1001;  10000; 10001; 11000; 11001}

так как 19=10011, то (Х&19≠0) = 0 при
X={100; 1000;  1100}
                   общее значение : Х=1000 (2сс) = 8 (10сс)

ответ 8
0,0(0 оценок)
Ответ:
ako91545
ako91545
18.06.2020 05:49

program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота