В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ьала
Ьала
12.04.2021 12:41 •  Информатика

Составьте программу, которая решает данную задачу, по следующему алгоритму: 1. Операторы вывода (поясняет назначение переменных)
2. Операторы ввода числовых данных (согласно количеству переменных).
3. Операторы присваивания (рассчитывают значения, согласно составленному
выражению)
4. Операторы вывода результата решения математических вычислений.


Составьте программу, которая решает данную задачу, по следующему алгоритму: 1. Операторы вывода (поя

Показать ответ
Ответ:
MIshaDo
MIshaDo
18.12.2022 05:43
Алгоритм

Суть алгоритма заключается в том, что робот проверяет, нет ли стены справа, и если её нет, то выполняет следующее:

делает шаг вправо;закрашивает клетку, в которой находится;делает шаг вправо.Движение

Исходя из данного алгоритма, робот закрасит клетки, отмеченные на прикреплённом изображении.

Распишем выполнение алгоритма более детально:

(я пронумеровал клетки, чтобы было легче понять процесс)

(вместо "клетка ..." буду писать "К...")

справа свободно: робот из К1 перемещается в К2, закрашивает К2 (1) и перемещается в К3.справа свободно: робот перемещается в К4, закрашивает К4 (2) и перемещается в К5.справа свободно: робот перемещается в К6, закрашивает К6 (3) и перемещается в К7.справа свободно: робот перемещается в К8, закрашивает К8 (4) и перемещается в К9.справа не свободно: цикл больше не выполняется.

ответ: 4.


Сколько клеток закрасит Робот, выполнив такой алгоритм? Стартовая позиция Робота на рисунке обозначе
0,0(0 оценок)
Ответ:
trubadurov01
trubadurov01
15.01.2023 23:11

2³ = 3 + 5

3³ = 7 + 9 + 11

4³ = 13 + 15 + 17 + 19

Заметим что во втором выражении первое число(7) получается как 3*(3-2)+1

В третьем аналогично: 13 получается как 4*(4-1)+1

Получаем формулу для первого значения: x1 = n*(n-1)+1

Остальные числа получаются путём прибавления 2 к предыдущему слагаемому. Так же заметим что число слагаемых равно числу которое мы возводим в степень.

x = int(input("Введите число: "))

xn = x * (x - 1) + 1  

rezultat = xn  

while (x != 1):

   xn += 2

   rezultat += xn

   x -= 1

 

print("Результат возведения в 3 степень:", rezultat)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота