В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
neponyatkiii
neponyatkiii
18.03.2023 19:10 •  Информатика

Составьте программу которая считывает три числа введенные и выводит наибольшее из них.

Показать ответ
Ответ:
kettyperry16
kettyperry16
25.06.2020 20:07

string chisla = "";

           int max = 0;

           Console.Write("Введите три числа через пробел: ");

           chisla = Console.ReadLine();

           int[] mas = new int[3];

           for (int i = 0; i < mas.Length; i++)

           {

               mas[i] = Convert.ToInt32(chisla.Split(' ')[i]);

           }

           for (int i = 0; i < mas.Length; i++)

           {

               if (mas[i] > max)

               {

                   max = mas[i];

               }

           }

           Console.WriteLine();

           Console.Write("Наибольшее число = {0}", max);

           

           Console.ReadKey();

Объяснение:

Язык не указан, написано на C#.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота