Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Kirillchakilev
01.12.2020 16:44 •
Информатика
Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не превосходящего 1000000000
Показать ответ
Ответ:
yuliyaduda11
04.10.2020 02:23
Function kr(n:longint):integer;
var
s:string;
begin
Str(Abs(n),s);
kr:=Length(s)
end;
var
k:longint;
begin
Write('Введите целое число: '); Read(k);
Writeln('В этом числе количество разрядов равно ',kr(k))
end.
Пример работы программы
Введите целое число: 1234567
В этом числе количество разрядов равно 7
0,0
(0 оценок)
Популярные вопросы: Информатика
Shiro1303
11.10.2022 08:06
В летнем лагере отдыхало 87 семиклассников (-а). 6 из них не любят компьютерные игры. 55 семиклассника (-ов) предпочитают квесты, 59 — симуляторы. Сколько ребят с одинаковым...
вика36100
19.10.2021 21:43
Задан массив действительных чисел. Записать и реализовать алгоритм удаления из массива нулевых элементов со сдвигом на их место следующих элементов без нарушения порядка...
АминаМингазова
07.06.2020 04:41
Установи соответствие между кодом и результатом программы....
noname3636
21.01.2021 19:43
Сколько решений имеет логическое уравнение A*B+C*D=1...
esrogalov
20.07.2021 21:14
Создаваемый документ состоит из рабочих листов. АдресРабочая книгаДиапазонЯчейкаПрограммное обеспечениеЭлектронная таблицаФормулыТабличный курсор...
artemmavericksmesrri
24.03.2020 05:44
Написать программу,выводящую порядковые номера всех букв т в строке.ABC Pascal...
natali030303nat
19.09.2020 05:18
Надо загрузить файл и там задания...
18000000
27.10.2022 15:20
В текстовом процессоре Word создаем таблицу. Напишите порядок действий, для создания ...
yaarichek
01.09.2020 16:50
Сделать в паскале: даны два вектора a=(a1,) b=(b1,) 1)вычислить длины векторов 2)вычислить скалярное произведение векторов 3) вычислить угол между a и b...
timashev94
26.09.2020 05:56
Можно ли прямоугольный пакет размерами a,b,c положить в чемодан размерами x,y,z?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
s:string;
begin
Str(Abs(n),s);
kr:=Length(s)
end;
var
k:longint;
begin
Write('Введите целое число: '); Read(k);
Writeln('В этом числе количество разрядов равно ',kr(k))
end.
Пример работы программы
Введите целое число: 1234567
В этом числе количество разрядов равно 7