В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
AbaiMalik05
AbaiMalik05
31.08.2021 17:53 •  Информатика

Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.

Показать ответ
Ответ:
Ilja0413
Ilja0413
14.08.2020 13:55
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>').ToWords.JoinIntoString;
  s.Println;
end.

Пример
>     А   роза   упала на     лапу    Азора
А роза упала на лапу Азора
0,0(0 оценок)
Ответ:
Топирчик
Топирчик
14.08.2020 13:55
Uses System;
uses System.Linq;var s: array of string;
a: string;
i, x: integer;begin
readln(a);
s := a.Split();
for i := 0 to s.Length - 1 do
  if (s[i].Length <> 0) then
    write(s[i] + ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота