В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
186Kbkz
186Kbkz
21.05.2023 21:48 •  Информатика

Составьте программу которая устанавливала бы нахождение повторяющихся букв в слове , т.е. показывала есть или нету .

Показать ответ
Ответ:
sitkovskiygleb
sitkovskiygleb
16.09.2020 08:50
Вот решение на паскале ABC, если нужно на другом языке программирования. Напишите на почту.
var
  a:string;
  c:char;
  n,i,i1:integer;
begin
  readln(a);
  for i:=1 to length(a) do begin
    c:=a[i];
    for i1:=i+1 to length(a) do begin
      if c = a[i1] then n:=n+1;
    end;
  end;
  if n>0 then writeln('В слове ',n,' пар букв') else writeln('Буквы не повторяются')
 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота