В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
viteralinap06rap
viteralinap06rap
05.12.2022 22:46 •  Информатика

Составьте программу которая в одномерном массиве состоящем из 20 случайных чисел (дробных) из промежутка (0;50) находит наибольший элемент

Показать ответ
Ответ:
amrah555
amrah555
23.08.2020 16:42

===== PascaslABC.NET =====

begin

 var a := ArrRandomReal(20, 0, 50);

 a.Println;

 Print('Max =', a.Max)

end.


Составьте программу которая в одномерном массиве состоящем из 20 случайных чисел (дробных) из промеж
0,0(0 оценок)
Ответ:
edakovagfffgg
edakovagfffgg
23.08.2020 16:42

var

 a: array[0..20] of real;

 i, iMax: integer;

 //iMax:real;

begin

 Randomize;

 iMax := 1;

 Writeln('Исходный массив');

 for i := 1 to 20 do

 begin

   a[i] := random(0.00, 50.00);

   Write(a[i]:0:2, #32);

 end;

 for i := 1 to 20 do

   if a[i] > a[iMax] then

   begin

     iMax := i;

   end;

 Writeln('Элемент номер: a[', iMax, '] ','максимальный. Значение: ', a[iMax]:0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота