В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nad17ka
Nad17ka
28.05.2020 04:31 •  Информатика

Составьте программу, которая в первую строку выводит названия зимних месяцев, во вторую - весенних, в третью строку - летних и в четвертую строку - названия осенних месяцев.

Показать ответ
Ответ:
100dan100
100dan100
21.02.2022 06:00

#include <iostream>

#include <vector>

using namespace std;

struct Year{

   vector<string> winter = {"December", "January", "February"},

                  spring = {"March", "April", "May"},

                  summer = {"June", "July", "August"},

                  autumn = {"September", "October", "November"};

};

void printWinter(Year &year_){

   for(auto &i: year_.winter)

       cout << i << " ";

   cout << "\n";

}

void printSpring(Year &year_){

   for(auto &i: year_.spring)

       cout << i << " ";

   cout << "\n";

}

void printSummer(Year &year_){

   for(auto &i: year_.summer)

       cout << i << " ";

   cout << "\n";

}

void printAutumn(Year &year_){

   for(auto &i: year_.autumn)

       cout << i << " ";

   cout << "\n";

}

signed main() {

   Year y;

   printWinter(y);

   printSpring(y);

   printSummer(y);

   printAutumn(y);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота