В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу, которая вставляет заданное слово z после указанного слова t строки s. Строки s, t, z вводятся с клавиатуры Входные данные:
землю покрыл снег {s}
покрыл {t}
пушистый {z}

Выходные данные:
землю покрыл пушистый снег

Показать ответ
Ответ:
anshul
anshul
01.12.2022 03:56

Звонит незнакомец, извиняется и говорит, что случайно указал ваш номер телефона в какой-то анкете. Он просит продиктовать ему код, который по ошибке пришел вам в СМС. Это точно мошенник. Немедленно бросайте трубку.

Мошенники могут притворяться, что они ваши знакомые, которые якобы хотят скинуть деньги вам на карту. Но для перевода им нужны номер карты, срок ее действия и CVC/CVV-код. Это тоже обман. Для того, чтобы перечислить деньги, достаточно номера карты. Никакие другие данные — срок действия, имя владельца или код — не требуются.

0,0(0 оценок)
Ответ:
aArisha2772
aArisha2772
27.10.2020 20:18

mobile_devices = {

   'cucuPhone': 2010,

   'cucuBlet': 2013,

   'cucuClock': 2015,

   'cucuEar': 2018,

   'cuCube': 2015,

}

home_devices = {

   'cucuLot': 2011,

   'cucuBlock': 2010,

   'cucuWall': 2010,

   'cucuMonitor': 2020,

   'cucuLamp': 2015,

   'cucuTable': 2016,

   'cucuTV': 2017,

}

not_supported_devices = {'cucuBlock', 'cucuBlet', 'cucuWall'}

result_supported = {}

# Функция объединяет ключи двух словарей в один set и возвращает его

def union_devices(devices_obj_1, devices_obj_2):

   set_1 = set(devices_obj_1)

   set_2 = set(devices_obj_2)

   union_set = set_1.union(set_2)

   return union_set

# Функция находит разницу двух сетов и возвращает её в виде set

def difference_device(all_devices, not_supported_devices):

   diff_set = all_devices.difference(not_supported_devices)

   return diff_set

# Функция копирует элементы из исходных словарей в результирующий словарь

def is_supported(dict_devices, device):

   if device in dict_devices:

       result_supported[device] = dict_devices[device]

# Вызываем union_devices(), чтобы получить полный перечень устройств

all_devices = union_devices(mobile_devices, home_devices)

# В result_devices сохранить сет, который вернёт функция difference_device()

result_devices = difference_device(all_devices, not_supported_devices)

# Перебрать в цикле сет result_devices и для каждого элемента  

# дважды вызвать функцию is_supported:

# - с аргументами mobile_devices, device

# - и с аргументами home_devices, device

for device in result_devices:

   is_supported(mobile_devices, device)

   is_supported(home_devices, device)

print(result_supported)

Объяснение:


Задача 3 Всемирно известная компания Cucumber выпускает мобильные гаджеты и устройства для «умного
Задача 3 Всемирно известная компания Cucumber выпускает мобильные гаджеты и устройства для «умного
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота