Составьте программу, которая вводит с клавиатуры 8 целых неотрицательных чисел (каждое число — с новой строки отдельной командой «ввод»), записывает их в массив, выводит на экран сначала в прямом порядке все без исключения элементы массива, затем, в обратном порядке относительно следования в массиве, все чётные элементы. например, для массива «1 2 5 4 5 3 7 8» программа должна выводить числа в таком порядке: 1 2 5 4 5 3 7 8 8 4 2. каждое число программа должна выводить в отдельной строке; ничего, кроме чисел, программа выводить не должна.
var
A:array [1..8] of byte;
i:integer;
begin
for i:=1 to 8 do readln(A[i]);
for i:=1 to 8 do writeln(A[i]);
for i:=8 downto 1 do
begin
if not Odd(A[i]) then writeln(A[i]);
end;
readln;
end.