В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ivabogdan
ivabogdan
07.12.2022 01:17 •  Информатика

Составьте программу, которая вычисляет произведение чисел от 1 до n. число n вводится с клавиатуры. с++

Показать ответ
Ответ:
12sa1900
12sa1900
09.10.2020 04:59
Код

#include <iostream>

using namespace std;

int main()

{

   // 1*2*3*4*5*6*7*8*9*10 = 3628800

   setlocale(LC_ALL, "Russian");

   unsigned int N;

   long long int Result = 1;

   cin >> N;

    for(int i = 1; i <= N; i++){

       Result = Result * i;

   }

   cout << endl << Result;

   return 0;

}

Проверка

10

3628800


5

120

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота