Составьте программу, которая выполняет чертеж детали и вычисляет ее площадь. маштаб 1 клетка - 20 пикселей, 1 клетка - 1 см. радиусы отверстий и вырезок (r1,r2,r3 и r4) вводятся с клавиатуры.
ответ:1Материнская плата – это главная системная плата компьютера, на которой расположены разъемы для комплектующих к ПК. Таким образом она служит основой всей электронной схемы компьютера. Поэтому благодаря материнской плате обеспечивается идеальное взаимодействие компонентов компьютера между собой. 2 Они выполняют записываемое в заголовках протоколов транспортного уровня модели 3 компьютер4Модульный принцип позволяет потребителю самому комплектовать нужную ему конфигурацию компьютера и производить при необходимости ее модернизацию. ... Модульная организация компьютера опирается на магистральный (шинный) принцип обмена информацией между устройствами.
ответ:1Материнская плата – это главная системная плата компьютера, на которой расположены разъемы для комплектующих к ПК. Таким образом она служит основой всей электронной схемы компьютера. Поэтому благодаря материнской плате обеспечивается идеальное взаимодействие компонентов компьютера между собой. 2 Они выполняют записываемое в заголовках протоколов транспортного уровня модели 3 компьютер4Модульный принцип позволяет потребителю самому комплектовать нужную ему конфигурацию компьютера и производить при необходимости ее модернизацию. ... Модульная организация компьютера опирается на магистральный (шинный) принцип обмена информацией между устройствами.
Объяснение:вроде так
#include <iostream>
#include <vector>
using namespace std;
int main() {int m, n, cx, cy;
cin >> m >> n;
vector<int>a;
a.reserve(m*n);
for (int i = 0;i < m;++i) {
for(int j = 0;j < n;++j) {
int v;
cin >> v;
a.push_back(v);
}
}
int x;
int value = 0;
cin >> x;
for (int k = 0;k < x;++k) {
cin >> cx >> cy;
if((a[cy-1 + (cx-1)*cy]) != -100) {
value += a[cy-1 + (cx-1)*cy];
a[cy-1 + (cx-1)*cy] = -100;
}
}cout << value;
}
Объяснение: