В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу, которая выполняет счёт от 1 до 10, при этом при счёте программа пропускает число 6.(Python)​

Показать ответ
Ответ:
Георгий11712
Георгий11712
22.06.2022 17:15
Нашел раз Системный блок небольшой дом. Залез в него и стал там жить. Пришла мышь и спрашивает:"Кто в теремке живет?"Системный блок ответил:"Я здесь живу, заходи вместе жить будем".Жили они хорошо.Пришел модем, спросил:"Кто в теремке живет?" А ему отвечают:"Мы, системный блок и мышь, заходи к нам."Стали вместе жить.Пришла клавиатура и спросила:"Кто тут живет?"Ей ответили:" Мы, системный блок, мышь и модем, заходи к нам." Стали вместе жить.Пришел монитор, спросил:"Кто здесь живет? "А ему ответили:"Нет места".Залез монитор на дом-теремок и стал там жить. Так появился компьютер. (домик-стол компьютерный)
0,0(0 оценок)
Ответ:
zhenyakulakova
zhenyakulakova
31.01.2020 03:24
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота