В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tara8808
Tara8808
11.03.2023 21:34 •  Информатика

Составьте программу, которая выводит на экран различные в зависимости от введенного времени. договоримся, что утро длится с 8 до 12 часов, день – с 12 до 17 часов, вечер – с 17 до 23 часов и ночь – все остальное время. program privet; var x: real; begin writeln('который час? '); read(x); if then writeln('доброе утро! '); if then writeln('добрый день! '); if then writeln('добрый вечер! '); if then writeln('доброй ночи! ') else writeln('введенное число не является временем ' ) ; end.

Показать ответ
Ответ:
doc2510
doc2510
10.06.2020 15:29

PROGRAM

Privet;

VAR

x:

real;


BEGIN

writeln(

'Который час?'); read(x);

if

x>

24 then

 

writeln(

'Введенное число не является временем ' )

else

begin

if 

(x>=

8) and (x<12)  then writeln('Доброе утро!');


if 

(x>=

12) and (x<17)    then writeln('Добрый день!');


if

(x>=

17) and (x<23)    then writeln('Добрый вечер!');

if

(x>=

23) or (x<8)  then writeln('Доброй ночи!');

end

;

end

.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота