В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ga1axI
Ga1axI
23.12.2021 15:17 •  Информатика

Составьте программу которая загружает из файлов и выводит на экран портреты писателей(купала. колас. быков) и зеркально отразите изображения вниз


Составьте программу которая загружает из файлов и выводит на экран портреты писателей(купала. колас.
Составьте программу которая загружает из файлов и выводит на экран портреты писателей(купала. колас.
Составьте программу которая загружает из файлов и выводит на экран портреты писателей(купала. колас.

Показать ответ
Ответ:
donya2014
donya2014
16.08.2022 19:22

Это очень не так просто, как кажется на первый взгляд

Объяснение:

Далеко не всегда кодировка была 8 бит на знак.

До сих пор применяется и довольно широко кодировка 7 бит на знак.

Давно уже применяются кодировки 16 и, даже 32 бита на знак.

Но, допустим, мы используем именно ОДИН байт на знак, например ASCII

Хотя и он изначально был семибитным.

1) Дано : в каждой строке 64 знака. Ключевое слово " в строке ",

то есть нам необходимо разделять строки. Для этого в конце каждой строки нужно передать еще два знака - " EOL " и " CR " (конец строки и переход в начало следующей)

Итого в строке 66 знаков.

2) Дано на странице 64 строки. То есть мы обязаны переводить страницы. Значит 64 *66 = 4224 Знака. И еще знак подачи ( перехода ) следующей страницы

Итого на странице 4225 знаков

2) Дано : в книге 128 страниц. Значит знаков 128 * 4225 = 540800 знаков

Это в Кибибайтах 540800 / 1024 = 528.125 Kib или

Или в Килобайтах 540800 / 1000 = 540,800 Kb

0,0(0 оценок)
Ответ:
imam1707
imam1707
26.01.2020 23:07

Объяснение:

1.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 while (i<=n) do begin

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 end;

 writeln(count);

 readln;

end.

2.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 repeat

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 until (i > n);

 writeln(count);

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота