В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alena7a1
alena7a1
27.01.2023 03:42 •  Информатика

Составьте программу, которая заполняет массив 6х6 следующим образом:
А)
1 0 0 0 0 0
0 1 0 0 0 0
0 0 1 0 0 0
0 0 0 1 0 0
0 0 0 0 1 0
0 0 0 0 0 1

Б)
1 0 0 0 0 0
1 1 0 0 0 0
1 1 1 0 0 0
1 1 1 1 0 0
1 1 1 1 1 0
1 1 1 1 1 1

В)
1 0 0 0 0 1
0 1 0 0 1 0
0 0 1 1 0 0
0 0 1 1 0 0
0 1 0 0 1 0
1 0 0 0 0 1

Показать ответ
Ответ:
Nastya8laif
Nastya8laif
29.01.2023 20:21

ответ: Проанализируем каждое число.

Число 1616 может быть результатом работы автомата, в этом случае исходное число могло быть 888.

Число 169 может быть результатом работы автомата, в этом случае исходное число могло быть 881.

Число 163 не может быть результатом работы автомата, поскольку в таком случае сумма среднего и старшего разрядов должна быть 16, а младшего и среднего — 3.

Число 1916 не может быть результатом работы автомата, поскольку нет таких цифр, сумма которых равна 19.

Число 1619 не может быть результатом работы автомата, поскольку числа записываются в порядке невозрастания.

Число 316 не может быть результатом работы автомата, поскольку числа записываются в порядке невозрастания, а число 31 невозможно получить сложением двух цифр.

Число 916 не может быть результатом работы автомата, поскольку числа записываются в порядке невозрастания.

Число 116 может быть результатом работы автомата,в этом случае исходное число могло быть 560.

ответ: 3.

Объяснение:

0,0(0 оценок)
Ответ:
0987mnbv
0987mnbv
20.12.2022 14:36
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота