В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
елена1810
елена1810
16.05.2021 06:01 •  Информатика

Составьте программу, которая заполняет массив а 1..0 случайными целыми числами в диапазоне от 1 до 10 и вычесляет сумму элементов массива с четными значениями

Показать ответ
Ответ:
ооооооолл
ооооооолл
04.10.2020 12:58
Program ex;

const
g = 100;

var
a, i, sum: integer;
b: array[1..g] of integer; // Не совсем понятен был размер массива. Мною было принято решение задать значение 100. Вы можете изменить его в любое время.
// Поменяв значение в константе g.
begin
sum := 0;
for i := 1 to g do 
begin
a := random(1, 10);
b[i] := a;
if b[i] mod 2 = 0 then
sum := b[i] + sum;
end;
write('Сумма массивов с четными значениями: ', sum)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота