В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
timur123123
timur123123
06.01.2022 20:11 •  Информатика

Составьте программу, которая заполняет массив а [1..10] случайными числами в диапазоне от 10 до 40, затем меняет местами 4 и 7 элемент массива. это pascal, 9 класс

Показать ответ
Ответ:
balbasenok
balbasenok
07.10.2020 06:57
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,10,40); a.Println;
  Swap(a[3],a[6]); a.Println
end.

Пример
15 19 29 28 27 20 37 34 39 31
15 19 29 37 27 20 28 34 39 31

Составьте программу, которая заполняет массив а [1..10] случайными числами в диапазоне от 10 до 40,
0,0(0 оценок)
Ответ:
limi10
limi10
07.10.2020 06:57
Var
  A: array [1..10] of byte;
  i, tmp: byte;
begin
randomize;
  for i := 1 to 10 do
    A[i] := random(31)+10;
  writeln('Сгенерированный массив.');  
  for i := 1 to 10 do
    write(A[i],' ');
  tmp := A[7];
  A[7] := A[4];
  A[4] := tmp;
  writeln;
  writeln('Измененный массив.');
  for i := 1 to 10 do
    write(A[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота