В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
карыч19
карыч19
25.05.2021 06:33 •  Информатика

Составьте программу, которая заполняет массив б(1..10) случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример вывода исходный массив : 10 2 4 1 3 5 7 8 количество пар чётных элементов = 2

Показать ответ
Ответ:
AAndrey7600
AAndrey7600
26.05.2020 12:36

#include <iostream>

 

int main()

{

 int b[10];

 for(int i=0;i<10;i++)

 { 

  b[i]=rand()%10+1;

 }

 int a=0;

 for(int i=0;i<9;i++)

 {

  if(b[i]%2==0 && b[i+1]%2==0)

   a++;

 }

std::cout<<"Чётных пар: "<<a<<std::endl;

system("PAUSE");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота