В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
18000000
18000000
11.08.2020 05:11 •  Информатика

Составьте программу, которая заполняет одномерный целочисленный массив из 100 элементов случайным образом в диапазоне от 1 до 40 , выводит заполненный массив на экран, а затем находит минимальный элемент и номер ячейки, которые после нахождения выводятся на экран

Показать ответ
Ответ:
Beliya1
Beliya1
05.10.2020 17:02
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
writeln('исходный массив:');
var a:=ArrRandom(100,1,40).Println();
var k:=1;
foreach var item in a do if item=a.Min then break else inc(k);
writeln('минимальный элемент: a[',k,']=',a.Min());
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота