В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sviridovakatya8
sviridovakatya8
01.03.2022 19:16 •  Информатика

Составьте программу, которая запрашивает число. Если введено положительное число, то на экран выводится квадрат этого числа. В противном случае выводится сообщение "Ошибка. Введено неправильное число" и повторный запрос на ввод нового числа.

Показать ответ
Ответ:
alex27045
alex27045
09.11.2021 13:30

Программа:

Python:

while True:

   n = int(input('Введите число: '))

   if n > 0:

       print(n * n)

       break

   else:

       print('Ошибка. Введено неправильное число')

Pascal:

var

 n: integer;

begin

 while True do begin

   write('n = '); readln(n);

   if n > 0 then begin

     writeln(n * n);

     break

   end

   else writeln('Ошибка. Введено неправильное число');

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота