В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Икари301202
Икари301202
25.02.2022 20:36 •  Информатика

Составьте программу которая запрашивает два числа и выводит меньшее из их суммы и произведения

Показать ответ
Ответ:
люси97
люси97
23.10.2021 21:58
Управляющий сайт _Портал_
Степень соответствия желаемому поиску в Интернете _Релевантность_
Базовый объект операционной системы Windows _окно_
Документ, взятый из Интернета _Веб-документ_
Сетевая карта _Адаптер_
Глобальная мировая компьютерная сеть _Интернет_
Часть URL адреса _Домен_
Электронная почта на английском языке _Е-mail_
Они бывают людские, природные, экономические, скрытые, аппаратные, программные, информационные, открытые, закрытые _Ресурсы_
Запишите первые буквы каждого термина и вы получите слово _ПРОВАИДЕР_
0,0(0 оценок)
Ответ:
Butuzovapelageya
Butuzovapelageya
21.03.2021 02:01
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

№1

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  Writeln('Количество отрицательных значений ',a.Where(t->t<0).Count);
end.

Пример
n= 15
3 39 3 2 43 43 -37 -2 -50 3 -25 15 -7 4 21
Количество отрицательных значений 5

№2

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var k:=ReadInteger('k=');
  if a.ElementsByRow.Any(t->t>k) then Writeln('Есть')
  else Writeln('Нет')
end.

Пример
Количество строк и столбцов в массиве: 5 8
*** Исходный массив ***
  -9  48 -98 -35 -33 -29  44 -32
 -33 -48 -62  11  45  53  52  90
 -96  -1  68 -21  15 -72 -78 -28
  44  15 -53 -33 -27  89 -60 -49
  28 -73 -99  81  23  -9 -93 -66

k= 92
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота