Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
anast0101
19.12.2021 04:30 •
Информатика
Составьте программу, которая запрашивает показания температуры t и рисует снежинку, если t< =0, или солнышко, если t> 0.
Показать ответ
Ответ:
Максуд22861827
11.03.2021 00:23
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
dashanarmania
25.05.2022 00:19
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nargizdjgalova
01.12.2022 10:20
составить блок-схему на основе псевдокода. Заранее...
polinasenchenk
07.01.2021 11:22
Айжан решила нарисовать векторное изображение. ей выбрать инструмент для преобразования фигуры....
Nazerke0606
26.03.2020 23:08
Вычислите значение выражения, записанного в префиксной форме : 5 8 * 5 2 * 10 + /- * - 9 3 4 + - 6 2 8...
viruvz
14.10.2021 21:52
Жауабы мен шешуи керек...
ДАШАСОКОЛОВА321
12.01.2020 04:51
6 сынып жаратылыс тану. такырып гылымнын роли...
Dinka2103
22.06.2020 13:10
можете написано с оформлением(т.е Дано, решение)1)Кинетическая энергия колеблющегося тела совершает гармонические ). Определить амплитудное значение кинетической энергии,...
Foxy4152
22.06.2020 13:10
Адаптація як властивість живого...
rayhan8888
11.04.2020 15:34
7/3Li+2/1 H- 8/4 Be+? литий изотобын дейтерий ядроларымен атқылағанда қандай бөлшек түзіледі?...
Владислав3212200
02.08.2022 10:08
Найдите производное функции: f (x)=7sinx-cos2π/7...
T4ffy
14.02.2022 08:13
Досжан кандай норма пажаж...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.