Составьте программу на паскале, которая вводит 2 целых числа m и n и печатает все целые числа между m и n, делящиеся на 7, включая и сами эти числа. замечание: программа должна учитывать, что заранее не известно, какое из чисел m или n больше другого.
var
N, M, prov: longint;
begin
readln(N);
readln(M);
if N < M then
begin
prov := N;
while prov <= M do
begin
if prov mod 7 = 0 then
writeln(prov);
inc(prov);
end;
end
else
begin
prov := M;
while prov <= N do
begin
if prov mod 7 = 0 then
writeln(prov);
inc(prov);
end;
end;
end.