В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KOI228
KOI228
14.06.2021 08:56 •  Информатика

Составьте программу на языке BASIC.
1. Высчитать площадь трапеции если известны высота, верхнее основание и разность между основаниями.
2. Компьютер здоровается с человеком, узнает его имя и. обращаясь по имени, сообщает, что сегодня - выходной.
3. Вычислить площадь треугольника по трем сторонам (формула Герона).
4. Вычислить время падения кирпича в секундах с крыши дома, если известны высота дома в метрах и, ускорение свободного падения

Показать ответ
Ответ:
хики2
хики2
11.09.2021 20:30

1. можно выделить лишь три основных вида алгоритмов (для краткости далее будем называть их линейные, разветвляющиеся и циклические алгоритмы):

• линейной структуры,

• разветвляющейся структуры,

• циклической структуры.

Линейный алгоритм – алгоритм, в котором порядок действий фиксирован и каждое действие выполняется только один раз.

Разветвляющаяся структура алгоритм, при выполнении которого каждый раз последовательность действий может быть разная. Схема подобного алгоритма обязательно содержит хотя бы один блок (символ) "решение", который и обеспечивает разветвление вычислительного процесса.

Алгоритм циклической структуры – это алгоритм, в котором предусмотрено неоднократное выполнение одной и той же последовательности действий. На практике часто встречаются задачи, в которых одно или несколько действий бывает необходимо повторить несколько раз.

2. Блок-схема — рас тип схем (графических моделей), описывающих алгоритмы или процессы, в которых отдельные шаги изображаются в виде блоков различной формы, соединенных между собой линиями, указывающими направление последовательности.

3. Псевдоко́д — компактный, зачастую неформальный язык описания алгоритмов, использующий ключевые слова императивных языков программирования, но опускающий несущественные для понимания алгоритма подробности и специфический синтаксис.

0,0(0 оценок)
Ответ:
zhoha2220
zhoha2220
03.09.2020 19:11
калькулятор сам составлял

#include<iostream>

 

using namespace std;

 

int main()

{

   setlocale( LC_ALL, "Russian" );

       float a,b,s;

       int dp;

       

   cout << "Привет! Я калькулятор!Какие действие вы будете выполнять:" << endl;

       cout << "1. Сложение. " << endl;

       cout << "2. Отнимание." << endl;

       cout << "3. Умножение." << endl;  

       cout << "4. Деление." << endl;

 

       cout << "Введите число для выбора действия" << endl;

 

       cin >> dp;

 

       switch(dp)

       {

       case 1:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a + b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

   break;

 

case 2:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a - b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

 

case 3:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a * b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

               case 4:

               cout << "Число a =  "  << endl;  

               cin >> a;

               cout << "Число b =  " << endl;

       cin >> b;

               s = a / b;

               cout << "\n" << a << " / " << b << " = "<< s << endl;

               break;

       }

       

 

return 0;

}

1

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота