В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
udekhdhdj
udekhdhdj
08.08.2020 07:35 •  Информатика

Составьте программу на языке C++,заменяющую меньшее из двух чисел модулем разности ,а большее-модулем произведения этих чисел.

Показать ответ
Ответ:
GardenBrid
GardenBrid
30.11.2020 15:25

#include <iostream>

#include <cmath>

using namespace std;

int main()  

{

 int first, second, temp;

 cin >> first >> second;

 if (first > second)

 {

   temp = first;

   first = abs(first * second);

   second = abs(temp - second);

 }

 else

 {

   temp = second;

   second = abs(second * first);

   first = abs(temp - first);

 }

 cout << first << " " << second;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

#include <cmath>  // Библиотека с математическими функциями

using namespace std;  // Пространство имен

int main()  

{

 int first, second, temp;  // Создание целочисленных переменных:

first - первое число, вводимое с клавиатуры;second - второе число, вводимое с клавиатуры;temp - переменная, для временного хранения одного из значений.

 cin >> first >> second;  // Вводим с клавиатуры первое и второе числа

 if (first > second)  // Если значение переменной first > значения переменной second

 {

   temp = first;  // Переменная временного хранения = значению переменной first

   first = abs(first * second);  // Значение переменной first (большей) = модулю произведения двух чисел

   second = abs(temp - second);  // Значение переменной second (меньшей) = модулю разности двух чисел

 }

 else  // Иначе

 {

   temp = second;  // Переменная временного хранения = значению переменной second

   second = abs(second * first);  // Значение переменной second (большей) = модулю произведения двух чисел

   first = abs(temp - first);  // Значение переменной first (меньшей) = модулю разности двух чисел

 }

 cout << first << " " << second;  // Выводим значения переменных first и second

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота