В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ИванПро228
ИванПро228
16.01.2022 11:53 •  Информатика

Составьте программу на языке Паскаль: Даны три числа a, b, c. Найдите периметр треугольника с
заданными сторонами. В программу нужно загрузить три числа.
Вывести на экран результат периметра P.

Показать ответ
Ответ:
мαрия
мαрия
03.03.2023 16:11
1-ое поколение: 1946 г. создание машины ЭНИАК на электронных лампах. Эти ЭВМ были  громоздкими сооружениями и занимали большую территорию. Для ввода программ и данных применялись перфоленты и перфокарты. Не было монитора, клавиатуры и мышки. Использовались эти машины для инженерных и научных расчетов.

2-ое поколение: 60-е годы. ЭВМ построены на транзисторах.
Машины стали компактнее, надежнее, менее энергоемкими. Возросло быстродействие и объем внутренней памяти. Большое развитие получили устройства внешней (магнитной) памяти: магнитные барабаны, накопители на магнитных лентах(кассеты). стали развиваться языки программирования высокого уровня: ФОРТРАН, АЛГОЛ, КОБОЛ. были изобретены интегральные схемы.

3-е поколение: 70-е годы. ЭВМ построены на интегральных микросхемах (ИС).
В Советском Союзе в 70-х годах начался выпуск машин серии ЕС ЭВМ (Единая система ЭВМ) по образцу IBM 360/370. Скорость работы  достигла уже нескольких миллионов операций в секунду. На машинах третьего поколения появился новый тип внешних запоминающих устройств – магнитные диски. Созданы большие интегральные схемы (БИС). 

4-ое поколение: Начало создаваться с 1971 г. с изобретением микропроцессора (МП). 
Создано на основе больших интегральных схем (БИС). Наиболее яркие представители четвертого поколения ЭВМ - персональные компьютеры (ПК). Персональной называется универсальная однопользовательская микроЭВМ. Связь с пользователем осуществлялась посредством цветного графического дисплея с использованием языков высокого уровня.
0,0(0 оценок)
Ответ:
aannnnn
aannnnn
10.01.2022 14:43
#include "iostream"
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#include <cstdio>
using namespace std;
void main()
{
setlocale(LC_ALL, "Russian");
 int i;
 double s = 0, k, size;
 double mas[200];
 cout << "Введите размерность массива:";
 cin >> size;
 srand(time(NULL));
 for (i = 0; i < size; i++)
{
 mas[i] = 0 + rand() % 100; cout << mas[i] << " ";
 }
cout << endl;
 for (i = 0; i < size; i++)
{
 s = s + mas[i];
 }
k = s / size;
 cout << "Среднее арифметическое:" << k <<endl;
 system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота