В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Lissa000
Lissa000
18.02.2020 21:37 •  Информатика

Составьте программу на языке паскаль для решения квадратного уравнения с разветлением

Показать ответ
Ответ:
ak067
ak067
20.03.2022 11:00

import java.util.Scanner;

public class Main {

  static int col=0;

   public static void main(String[] args) {

       Container c1 =new Container(10,4,2.5);

       v2(c1);

       System.out.println(col);

   }

   static void v2(Container container) {

       System.out.println("Ведите размеры авто");

       Scanner scanner = new Scanner(System.in);

       double l= scanner.nextInt();

       double h=scanner.nextInt();;

       double w=scanner.nextInt();;

       Car car = new Car(l,h,w);

       if (container.hashCode() >= car.hashCode()) {

           container.widht = container.widht - car.widht;

           container.height= container.height - car.height;

           container.leng = container.leng - car.leng;

            col++;

            v2(container);

           }

   }

}

public class Car {

    final double leng;

    final double height;

    final double widht;

   Car(double leng,double height,double widht){

       this.leng=leng;

       this.height=height;

       this.widht=widht;

   }

   @Override

   public int hashCode() {

       return (int) (leng+height+widht);

   }

}

public class Container {

    static double leng;

    static double height;

    static double widht;

   Container(double leng,double height,double widht){

       this.leng=leng;

       this.height=height;

       this.widht=widht;

   }

   @Override

   public int hashCode() {

       return (int) (leng+height+widht);

   }

}

0,0(0 оценок)
Ответ:
superpuperkrosh
superpuperkrosh
13.02.2023 07:10
Замечание надеемся, что вы еще не забыли о позиционном принципе записи чисел в любых системах счисления (значение цифр, количество которых ограничено, зависит от положения в числе, от ее позиции).в данный момент мы делаем шаг в сторону абстрагирования от конкретных значений цифр и начинаем считать только количество знакомест (позиций), которое в принято называть "разрядом", а совокупность разрядов (знакомест) — "разрядностью". определение разряд в арифметике — это место, занимаемое цифрой при записи числа. например, в десятичной системе счисления цифры первого разряда — это единицы, второго разряда — десятки и т. д. но арифметические законы, которые кажутся привычными в десятичной системе счисления, все без исключения действительны и для двоичной системы счисления. двоичные числа также можно складывать, вычитать, перемножать и делить с использованием тех же приемов школьного курса арифметики. отличие заключается только в том, что используются всего две цифры. кроме того, как мы уже выяснили, в двоичной системе счисления каждый разряд — это бит и его значение зависит от позиции и равно соответствующей степени числа "2". определение разрядность двоичного числа — это количество знакомест (разрядов) или количество битов, заранее отведенных для записи числа. пример десятичное число "2" может быть записано различными способами в зависимости от разрядности двоичного числа: как "10", если разрядность равна двум; как "0010", если разрядность равна четырем; как "00000010", если разрядность равна восьми. обратите внимание, что последний вариант соответствует записи десятичного числа "2" в пределах одного байта информации. разрядность двоичного числа интересует нас в связи с тем, что это количество разрядов (позиций или знакомест) обеспечивает определенный набор возможных двоичных чисел, которые, как мы уже договорились, могут служить , с которых происходит кодирование любых видов информации: собственно чисел, текстов, графических и цветных изображений, звуков, анимации и видео. осталось только выяснить, каким образом разрядность влияет на количество информации (двоичных кодов), котоую можно получить с определенного количества разрядов. однако прежде следует учесть одну особенность двоичных чисел, нашедшую применение в компьютерных технологиях, — это фиксированные значения разрядности двоичных чисел.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота