В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
asdf37
asdf37
08.12.2022 23:08 •  Информатика

Составьте программу на языке паскаль для решения . с клавиатуры вводятся 5 действительных чисел. найти сумму всех чисел, больше 5. и произведение всех чисел, меньше 1.

Показать ответ
Ответ:
marinamirom1
marinamirom1
07.10.2020 05:11
Const n =5;
var
  a: array[1..n] of integer;
  i,k,s,p:integer;
begin
s:=0;
p:=1;
for i:=1 to n do
  begin
  readln(a[i]);
  if(a[i] >= 5) then
      s:=s+a[i] else
  if (a[i] <1) then
      p:=p*a[i];
  end;
 writeln('Исходные числа');
for i:=1 to n do
    write(a[i]+ ' ');
writeln;
writeln('Сумма чисел больше 5 : ',s:2);
writeln('Произведение меньше 1 : ',p:2);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота