В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
olgaerchik
olgaerchik
11.02.2020 19:56 •  Информатика

Составьте программу на языке Паскаль для задачи: Дана строка ‘каждый человек обязан (я подчеркиваю – обязан!) заботиться о ближнем’. Удалить часть символьной строки в скобках (вместе со скобками).

Показать ответ
Ответ:
Даниил223223
Даниил223223
13.01.2021 00:36
Program Pascal1;
uses Crt;
const
  m=4;
  n=2;
var
  a:array[1..m,1..n] of real;
  i,j,k:integer;
begin
  ClrScr;
  Randomize;
  Writeln('Сформированный масcив');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(31)-15.0;
      Write(a[i,j]:6:1);
      if a[i,j]=10 then Inc(k)
      end;
    Writeln
  end;
  Writeln('Количество элементов, равных 10: ',k);
  Write('Нулевые элементы: ');
  for i:=1 to m do
    for j:=1 to n do
      if a[i,j]=0 then Write('a[',i,',',j,'] ');
  Writeln
end.

Вариант выполнения:
0,0(0 оценок)
Ответ:
dimakrochak
dimakrochak
20.05.2022 08:06
Флеш-память — память типа Flash — разновидность полупроводниковой технологии электрически перепрограммируемой памяти (EEPROM). В народе флеш-памятью называют широкий класс твердотельных устройств хранения информации. Флеш-память (в отличие от винчестеров) используют в накопителях смартфонов, особого класса ноутбуков (по причине дороговизны этого типа памяти) и кое-где еще. Особенность этого типа памяти, помимо дороговизны и быстродействия — конечное число циклов перезаписи. Также практически невозможно найти накопители с флеш-памятью большого объема.Компакт-диск (англ. Compact Disc, CD) — оптический носитель информации в виде пластикового диска с отверстием в центре, процесс записи и считывания информации которого осуществляется при лазера. Дальнейшим развитием компакт-дисков стали DVD и Blu-ray, прообразом была граммофонная пластинка.

Изначально компакт-диск был создан для хранения аудиозаписей в цифровом виде (известен как CD-Audio), однако в дальнейшем стал широко использоваться как носитель для хранения любых данных (файлов) в двоичном виде (т.н. CD-ROM — англ. Compact Disc Read Only Memory, компакт-диск с возможностью только чтения, или КД-ПЗУ — «Компакт-диск, постоянное запоминающее устройство»). В дальнейшем появились компакт-диски с возможностью не только чтения однократно занесённой на них информации, но и записи (CD-R — англ. Compact Disc-Recordable, записываемый компакт-диск) и перезаписи (CD-RW — англ. Compact Disc-ReWritable, перезаписываемый компакт-диск).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота