Составьте программу на языке программирования Паскаль, в которой требуется выполнить следующие действия: • Пользователь задает с клавиатуры последовательность из n целых чисел (n также определяется пользователем). Найти среднее арифметическое чисел из этой последовательности.
var N,x,S,i:integer;
SR:real;
begin
writeln ('кол-во чисел в последовательности N=');
readln (N);
S:=0;
for i:=1 to N do
begin
read (x);
S:=S+x;
end;
Sr:=S/N;
Writeln('Sr=',Sr)
end.
Объяснение:
--- PascalABC.NET 3.6.2 ---
begin
var N := ReadInteger();
var S := ReadSeqInteger(N);
S.Average.Println;
end.