В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sasha2005k1
sasha2005k1
02.11.2021 09:35 •  Информатика

Составьте программу на языке python , которая по введенному вами k – числу грибов печатает фразу «мы нашли в лесу k грибов», причем согласовывает окончание слова «гриб» с k. (количество грибов может быть любым целым положительным числом: 1, 3, 34, 127 и т.д. окончание фразы определяется значением последней цифры.) 

Показать ответ
Ответ:
yfbft
yfbft
04.04.2019 17:00

var

  k: integer;

begin

  readln(k);

  if k< 0 then

    writeln('не может такого быть')

  else

    begin

      write('мы нашли в лесу ',k,' гриб');

      if (k mod 100 in [5..19]) then

        writeln('ов')

      else if (k mod 10 in [2..4]) then

        writeln('а')

      else if (k mod 10=1) then

        writeln

      else

        writeln('ов');

    end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота