В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lizamrio1
lizamrio1
18.01.2021 05:04 •  Информатика

Составьте программу на языке С+ для решения данной задачи. В ответе записать код.


Составьте программу на языке С+ для решения данной задачи. В ответе записать код.

Показать ответ
Ответ:
CCQ
CCQ
31.12.2022 20:11
Все модели можно разбить на два больших класса: модели предметные (материальные) и модели информационные. Предметные модели воспроизводят геометрические, физические и другие свойства объектов в материальной форме (глобус, анатомические муляжи, модели кристаллических решеток, макеты зданий и сооружений и др.) .
Информационные модели представляют объекты и процессы в образной или знаковой форме.
Образные модели (рисунки, фотографии и др. ) представляют собой зрительные образы объектов, зафиксированные на каком-либо носителе информации (бумаге, фото- и кинопленке и др.) . Широко используются образные информационные модели в образовании (вспомните учебные плакаты по различным предметам) и науке, где требуется классификация объектов по их внешним признакам (в ботанике, биологии, палеонтологии и др.) .
Знаковые информационные модели строятся с использованием различных языков (знаковых систем) . Знаковая информационная модель может быть представлена в форме текста (например, программы на языке программирования) , формулы (например, второго закона Ньютона F=m·a), таблицы (например, периодической таблицы элементов Д. И. Менделеева) и так далее.
Иногда при построении знаковых информационных моделей используются одновременно несколько различных языков. Примерами таких моделей могут служить географические карты, графики, диаграммы и пр. Во всех этих моделях используются одновременно как язык графических элементов, так и на протяжении своей истории человечество использовало различные и инструменты для создания информационных моделей. Эти постоянно совершенствовались. Так, первые информационные модели создавались в форме наскальных рисунков, в настоящее же время информационные модели обычно строятся и исследуются с использованием современных компьютерных технологий.
0,0(0 оценок)
Ответ:
Ертилеу
Ертилеу
08.04.2023 13:28

1)

var mas: array[1..10] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания

var counter: integer;

begin

for i:= 1 to 10 do

begin

if mas[i]<0 then counter:=counter+1;

end;

end.

2)

var mas: array[1..5] of integer = {.,.,}; // перечисление элементов массива, который дан по условию задания

var counter: integer;

begin

for i:= 1 to 5 do

begin

if (mas[i]>0) and (i mod 2 = 0) then counter:=counter+1;

end;

end.

3)

var mas: array[1..15] of integer = {.,.,}; // перечисление элементов массива, который дан по условию задания

var counter: integer;

begin

for i:= 1 to 15 do

begin

if (mas[i]>5) and (i mod 2 = 0) then counter:=counter+1;

end;

end.

4)

var mas: array[1..15] of integer;

var counter: integer;

begin

for i:= 1 to 15 do

begin

mas[i] = random(20) - 5;

end;

for i:= 1 to 15 do

begin

writeln(mas[i]);

end;

for i:= 1 to 15 do

begin

if (mas[i]>0) then counter:=counter+1;

end;

end.

5)

var mas: array[1..7] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания

var counter: integer;

begin

for i:= 1 to 7 do

begin

readln(mas[i]);

end;

for i:= 1 to 7 do

begin

if mas[i]>0 then mas[i]=0;

end;

for i:= 1 to 7 do

begin

writeln(mas[i]);

end;

end.

6)

var mas: array[1..10] of real = {.,.,}; // перечисление элементов массива, который дан по условию задания

var counter: integer;

var sum: real;

var average: real;

begin

for i:= 1 to 7 do

begin

readln(mas[i]);

end;

for i:= 1 to 7 do

begin

if mas[i]<0 then

begin

sum:=sum+mas[i];

counter:=counter+1;

end

end;

average:= sum/counter;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота