Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
axeltrofimsky
24.10.2021 02:21 •
Информатика
Составьте программу, находящую кол-во делителей числа х. число х введите с клавиатуры. (pascal abc (не net))
Показать ответ
Ответ:
Help102
07.10.2020 08:32
//программа находит количество всех делителей числа, включая само число и 1
Program n1;
var x,i,k: integer;
begin
readln(x);
k:=0;
for i:=1 to x do if x div i=x/i then k:=k+1;
write('кол-во целых делителей числа ',x,': ',k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
KowMAp
13.10.2021 15:36
Составьте программу определения знака произведения трёх чисел. нужно написать на языке basic....
freight1337
13.10.2021 15:36
Вчем ошибка? сразу выделяет вторую строку и пишет ошибку declaration expected but identifier s found я уже весь интернет облазила, но не понимаю, в чем суть ошибки uses sysutils;...
рпрпрп1
16.01.2020 17:37
Фирма продает а квартир по цене 6550000 руб. за каждую. найти общую выручку от продажи квартир решение...
prokopchukalex
16.01.2020 17:37
Какие элементы используются для создания процессоров в современной компьютерной технике?...
Stasikone
16.01.2020 17:37
Составить программу вычисления значения выражения y=x-x3/3...
лена2611
16.01.2020 17:37
Описать множества alf( a .. я ) и поместите в него гласные буквы...
ирина1523
08.04.2021 23:05
Конспект по циклу с постусловием в паскале ( механизм выполнения, особенности написания,план решения с этии циклом)...
dashakid1
08.04.2021 23:05
Переведите -323 из десятичной системы в двоичную в двухбайтовом формате...
sa66
08.04.2021 23:05
Стаблицы решим следующую . на школьном дворе разбивают 5 клумб треугольной формы. первая клумба представляет собой равнобедренный треугольник с длинами сторон 5, 5 и 7 метров....
Никита92111
01.04.2021 10:07
Вводится n натуральных чисел. найти минимальное, кратное 7. если такого числа нет, вывести нет . с++...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Program n1;
var x,i,k: integer;
begin
readln(x);
k:=0;
for i:=1 to x do if x div i=x/i then k:=k+1;
write('кол-во целых делителей числа ',x,': ',k);
end.