В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Mashylka999
Mashylka999
08.10.2020 17:19 •  Информатика

Составьте программу, находящую количество делителей числа х. число х введите с клавиатуры. (pascal abc (не net))

Показать ответ
Ответ:
Дианочка140
Дианочка140
07.10.2020 08:32
Var n, i, sum: integer; //Описание переменных Begin //Начло программы writeln ('Введите число'); //Диалог с пользователем readln(n); //Считывание числа sum := n; //Присваивание сумме значение самого числа (само число - уже делитель самого себя) writeln('Делители числа:'); //Диалог с пользователем for i := 1 to n div 2 do //Цикл For от до половины n if (n mod i) = 0 then begin //Если число делится на i, то выводим write(i,' '); sum := sum + i; //К значению суммы прибавляем делитель end; //Конец условного оператора if writeln(n); //Вывод самого числа, т.к. оно тоже делитель writeln('Сумма делителей: ',sum); //Вывод суммы делителей End.
0,0(0 оценок)
Ответ:
sashakoritnij
sashakoritnij
07.10.2020 08:32
Program A;var X,sum,i: integer;beginsum := 0 ;Readln(X);for i:= 1 to X doif (X  mod i = 0) then   sum := sum + 1;Writeln(sum);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота