В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Злата1616
Злата1616
02.10.2022 12:36 •  Информатика

Составьте программу нахождения наибольшего общего делителя для двух чисел. (воспользоваться алгоритмом евклида). алгоритм евклида поиска наибольшего общего делителя двух чисел: вычитай из большего меньшее, пока числа не станут равны. полученное значение и будет искомым.

Показать ответ
Ответ:
ангелина123456543216
ангелина123456543216
24.06.2020 16:25
Var  a, b: word;
function NOD(x, y: integer):integer;
begin 
repeat    
 if abs(x) > abs(y) then      
 x := x mod y    
else    
  y := y mod x;  
until (x = 0) or (y = 0); 
  NOD := abs(x + y);
 end;
begin 
 write('a=');read(a);  
 write('b=');readln(b); 
writeln('NOD(a,b)=', NOD(a, b)); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота