Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Poli4ka228
11.02.2020 19:12 •
Информатика
Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу: нод(а, b, с) = нод(нод(a, в), с). испоьзуя алгоритм евклида
Показать ответ
Ответ:
tyler02169
12.06.2020 07:17
Var
a, b, c: longint;
function nod(a, b: longint): longint;
begin
a := abs(a);
b := abs(b);
if a * b = 0 then nod := 1
else begin
while a <> b do
if a > b then
a := a - b
else
b := b - a;
nod := a;
end;
end;
begin
read(a, b, c);
writeln(nod(nod(a, b), c));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ggf6fr
11.04.2021 09:14
Какое значение будет присвоено переменной y после выполнения следующего кода? 50 5 0.5 10...
aimnura73
17.12.2022 16:58
Чему будет равно значение переменной s после выполнения фрагмента кода при n = –4? if n 0 then s:=n-7 else s:= n+7;...
kosen2332
11.08.2020 16:15
Укажите строк(-и), в которо(-ых) присутству(-ют) ошибк(-и)....
natalyater1
24.01.2022 19:33
5примеров комбинированной информации....
nastyakelman25
10.10.2022 07:54
Начало | a:=14,b:=9,c:=6 | (a-b) c a:=c-b a:=b-c | | | a | Конец с информатикой.Очень нужно! Нужно вычислить переменную по блок схеме. Очень вас Начало | a:=14,b:=9,c:=6 |...
ЛидияЕрулаева17
26.09.2020 10:00
Рассмотренные алгоритмы можно реализовывать и по-другому. Определите, код какого алгоритма приведён ниже: for i in range(n - 1): for j in range(i + 1, n): if arr[i] arr[j]:...
AleksandrO0s
27.05.2020 21:23
Сколько машинных команд будет выполнено при вызове процедуры writeln, которая выводит результат функции div2()? Ассемблер...
касымжомарттокаев1
01.09.2021 02:30
Community.ibm.com/community/user/network/members/profile?UserKey=04ce14b2-3d1d-4a39-bc0b-1f7bb0cde056 surveymonkey.com/r/8B9ZR8H twitter.com/japan_derby2020 nac.ge/watch/Au1e6xO3QVGwUgW...
valerysidochenozpzmu
10.12.2020 12:17
Дан список из 10 элементов: 8 1 7 4 3 9 2 5 6 10 Как будет выглядеть список после 3-х шагов вставки в алгоритме сортировки вставками? Введите список чисел, разделённых пробелами....
ОляФомина
10.12.2020 12:17
Вычислите сдачу с покупки музыкального диска, если диск стоит m рублей, а у вас в кармане n рублей. Написать код на паскале и сделать схему...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a, b, c: longint;
function nod(a, b: longint): longint;
begin
a := abs(a);
b := abs(b);
if a * b = 0 then nod := 1
else begin
while a <> b do
if a > b then
a := a - b
else
b := b - a;
nod := a;
end;
end;
begin
read(a, b, c);
writeln(nod(nod(a, b), c));
end.